Merkaartor

Aus wiki.archlinux.de
Wechseln zu: Navigation, Suche
Leicht angepasste Editieransicht mit OSM-Mapnik im Hintergrund und einer markierten Fläche (Gebäude)
Informationsdialog von Merkaartor 0.18(release)

Merkaartor ist ein leider nur sehr langsam entwickelter, aber sehr ausgereifter und komplexer Mapper (Karteneditierprogramm), der offiziell vom OpenStreetMap-Projekt (OSM) empfohlen wird, und der entsprechende Schnittstellen zum Down- und Upload der OSM-Daten bereitstellt.

Installation

Merkaartor ist als merkaartorAUR im AUR verfügbar, und kann von dort zum Beispiel mittels Yaourt installiert werden.

yaourt -S merkaartor
Bei der Verwendung von Yaourt ist zu beachten, dass Pakete niemals „blind“ installiert werden sollten. Vor dem Installieren mit Yaourt sollten die Kommentare im AUR gelesen, und das PKGBUILD geprüft werden.

Da Merkaartor ein Qt4-Programm ist, passt es sich unter Umständen nicht in ein GTK-Umfeld ein. Um dem etwas entgegenzuwirken, kann man mittels qtconfig-qt4 unter „Appearance → GUI Style → Select GUI Style“ die Auswahl auf „GTK+“ stellen. Qt stellt das Theme dann gemäß des GTK-Aussehens aus der .gtkrc-2.0 ein. Eventuell muss man export GTK2_RC_FILES="$HOME/.gtkrc-2.0" in z.B. die xinitrc setzen, damit qtconfig-qt4 die richtige GTK-Konfigurationsdatei liest.

Konfiguration

Nach der Installation ist das Programm mittels merkaartor zu starten. Zuerst sollte man über „Tools → Preferences → Locale“ die Sprache, indem man das Häkchen vor „Use language“ aktiviert, und dort „German“ auswählt, auf Deutsch umstellen. Mittels „Apply“ wird die Sprache direkt angepasst. Im folgenden geht der Artikel von der Deutschen Sprachversion aus.

Um OSM-Daten nicht nur herunter- sondern auch die veränderten Daten wieder hochladen zu können, benötigt man einen OSM-Account Sprache de.png. Die Daten des Accounts werden unter „Daten → OSM API“ eingestellt. Mittels der Plus- und Mins-Buttons können weitere Accounts hinzugefügt, bzw. entfernt werden. Die URLs sollten auf ihren Standardwerten belassen werden.

Sofern man Merkaartor zum Live-Mapping verwenden möchte, sollte man unter dem Registerreiter „GPS“ die GPS-Quelle wählen, hier besteht die Möglichkeit, sowohl gpsd, als auch ein Serielles GPS-Gerät auszuwählen.

Das GUI

Das wichtigste Element von Merkaartor ist neben der eigentlichen Bearbeitungsfläche dessen Menüzeile. Die Leiste ist über „Werkzeuge → Symbolleisteneditor“ anpassbar.

Ausgeklappte Menüzeile

Neben den Buttons zum Hoch- und Runterladen der OSM-Daten gibt es hier auch Speichermöglichkeiten, die gängigen Kopieren/Einfügen-Buttons, sowie diverse weitere Buttons: Für das Auswählen, Verschieben, Drehen und Skalieren von Flächen, zum Erstellen von neuen Punkten und Flächen, und die Bearbeitungsoptionen für bestehende Kartenelemente.

Die Tastenkombinationen sind über „Werkzeuge → Tastenkürzeleditor“ konfigurierbar, und bietet für diverse Standardoptionen bereits vordefinierte Einstellungen.

Die einzelnen Infokästen des GUIs sind abdockbar, ähnlich, wie bei GIMP die einzelnen Registerreiter aus den Werkzeugkästen im Mehrfenstermodus abdockbar sind. Mittels des x-Buttons in den einzelnen Kästen lassen die Dialoge sich schließen, der andere Button löst sie aus dem Hauptfenster, bzw. bringt sie dort hin zurück. Über „Fenster → Unterfenster“ lassen sich geschlossene Fenster wieder aktivieren.

Verwendung

Anzeige eines einzelnen Punktes

Da eine Einführung in die OSM-Datenverwaltung und die Merkaartor-Bedienung den Rahmen dieses Artikels sprengen würde, sei für eine tiefer gehende Einführung auf die Weblinks und die selbständige Webrecherche verwiesen. OSM hat eine sehr starke deutsche Community, so dass alle relevanten Dinge zu OSM und auch zu Merkaartor im Regelfall auch auf Deutsch verfügbar sind.

Generell ist der Arbeitsablauf derart, dass man sich über den TMS- oder WMS-Adapter eine Karte in den Hintergrund legt, oder bestehende Luftbilder verwendet, und anhand dieser durch Flächen, Linien und Punkte die Karte erstellt. Dabei sind die Lizenzbedingungen zu beachten (vgl. hierzu die FAQ zu Quelldaten Sprache de.png). Alternativ kann man auch selbst aufgezeichnete GPS-Tracks, oder Live-Tracking innerhalb von Merkaartor mit einem angeschlossenen GPS-Gerät verwenden.

Nachdem man die Kartenelemente erstellt oder angepasst hat, lädt man das Ergebnis über „Hochladen“ in die OSM-Datenbank, man kann die Daten auch lokal speichern, und später daran weiterarbeiten. Nach dem Hochladen dauert es einige Minuten, bis Mapnik (der OSM-Standard-Renderer) aus den neuen Daten die entsprechenden Kartenkacheln generiert hat.

Siehe auch

  • JOSM – ein anderer, tiefer greifenderer OSM-Editor
  • GPS – zur Einrichtung von gpsd

Weblinks