JOSM

Aus wiki.archlinux.de
Version vom 22. Juni 2013, 19:27 Uhr von Dirk (Diskussion | Beiträge) (Buildings Tools)

(Unterschied) ← Nächstältere Version | Aktuelle Version (Unterschied) | Nächstjüngere Version → (Unterschied)
Wechseln zu: Navigation, Suche
JOSM zeigt einen Kartenausschnitt an. Das Programm ist bereits angepasst und durch Plugins erweitert, und es werden im Hintergrund abgeschwächt Luftbilder angezeigt

JOSM ist ein aktiv in Java entwickelter, fortschrittlicher, sehr umfangreich konfigurier- und nutzbarer, und durch Plugins nahezu beliebig erweiterbarer Mapper (Karteneditierprogramm) für das OpenStreetMap-Projekt. Da JOSM offiziell von OSM unterstützt und befürwortet wird, ist das Programm im Bezug auf OSM-Möglichkeiten sehr aktuell, und bietet alle jeweilig aktuellen Funktionen.

Installation

Das Programm ist als josm in community verfügbar, und kann von dort mittels Pacman installiert werden.

pacman -S josm

Da JOSM in Java entwickelt wurde, wird eine Java-Version benötigt. JOSM funktioniert mit jre7-openjdk einwandfrei.

Konfiguration

EInstellungen des Datenprüfungs-Plugins

Die Konfigurationsmöglichkeiten von JOSM sind sehr vielfältig, und können an die individuelle Nutzungsweise und den individuellen Geschmack angepasst werden. So können unter anderem Tastenkombinationen, die zahlreichen Vorlagen, oder die Projektionsmethode geändert werden. Aber auch die Anzeige der einzelnen Linienfarben je nach Bedeutung kann konfiguriert werden.

Für den Down- und Upload der OSM-Daten muss der OSM-Account eingetragen werden. Dies geschieht unter „Bearbeiten → Einstellungen → Verbindungseinstellungen“ (Weltkugel mit Stecker) im Abschnitt „Authentifizierung“.

Über den Abschnitt „Fernsteuerung“ (Fernbedienungssymbol) kann JOSM einen lokalen Server bereitstellen, über den man z.B. von der OSM-Website aus direkt einen Kartenausschnitt laden kann.

Plugins

Mittels der bereits verfügbaren Plugins kann JOSM sehr stark erweitert werden. Plugins sind über „Bearbeiten → Einstellungen“ (F12) unter „Plugins“ (Stecker und Steckdose) innerhalb des Programms installier- und wartbar. Zuerst muss man die Liste mittels „Liste herunterladen“ aktualisieren, und kann dann die Plugins aktivieren. Über „Plugins aktualisieren“ werden die Plugins geladen.

Die Plugin-Beschreibungen geben Aufschluss über die jeweilige Funktion des Plugins, wobei man immer über „Mehr Info...“ Details zum Plugin nachlesen sollte, da nicht jeder alle Plugins benötigt. Um die Codebasis gering zu halten, sollten nur tatsächlich genutzte Plugins geladen werden.

Über den Registerreiter „Plugin-Aktualisierungsstrategie“ kann festgelegt werden, ob und wie Plugins aktualisiert werden sollen. Es empfiehlt sich hier, sowohl bei der Bei-Start-Prüfung als auch bei der Intervallprüfung auf „Vor Aktualisierung fragen“ zu stellen.

„Standardplugins“

Neben dem Funktionsumfang von JOSM selbst haben sich einige Plugins als eine Art „Standard“ unter Mappern etabliert.

UtilsPlugin2

Das Menü „Werkzeuge 2“

Dieses Plugin stellt ein zweites komplettes Set an Werkzeugen unter „Werkzeuge 2“ bereit.

So können zum Beispiel „intelligent“ angrenzende Knoten markiert werden, wobei zuletzt „benutzte“ Wege bevorzugt werden. Auch können bei sich überlappenden Flächen an den Schnittpunkten Knoten erstellt werden, oder alle Linien oder Flächen markiert werden, die eine andere Linie schneiden.

Ebenfalls besteht die Möglichkeit, Flächen zwischen zwei ausgewählten Randknoten zu spalten, Kreisbögen zu erstellen, gezielt an bestimmten Längen- und Breitengraden Punkte zu setzen, oder Merkmale und Relationen zu kopieren und wieder einzufügen.

Buildings Tools

Hauptfenster des Gebäudeplugins

Um in JOSM rechteckige Gebäude zu erstellen, benötigt man zuerst vier Linien, deren Punkte man verbindet, dann muss man über „Werkzeuge → Form rechtwinklig machen“ (Q) das Rechteck sauber ausrichten, und dann das Tag building=yes setzen. Buildings Tools vereinfacht dieses Vorgehen.

Über den Quader-Button in der linksseitigen Menüspalte oder B wählt man das Gebäudewerkzeug aus. Nun klickt man an einen Eckpunkt des zu erstellenden Gebäudes, und zieht dann eine Linie zum zweiten Eckpunkt auf der selben Seite des Gebäudes. Nun kann man ein Rechteck auf die Größe, in der man das Gebäude benötigt, aufziehen.

Über „Bearbeiten → Größe des Gebäudes“ kann man zudem Breite und Schrittweite in Metern, sowie weitere Optionen einstellen. Mittels „Erweitert“ besteht zudem die Möglichkeit zusätzliche Tags für Gebäude zu bestimmen.

Wenn man bei Verwendung des Tools schon ein Gebäude markiert hat, richtet sich das neu zu zeichnende Gebäude automatisch parallel zum bereits markierten Gebäude aus.

Terracer

Das Hauptfenster (rechts) und zwei Anwendungsbeispiele (links)

Der Terracer ermöglicht das schnelle und einfache Aufteilen von Gebäuden, wobei Hausnummern nach verschiedenen Schemata, sowie die Straße gleich automatisiert mit-gesetzt werden können. Zu erreichen ist das Tool über „Werkzeuge → Gebäude Abteilen“.

Man stellt entweder ein, wie viele Abschnitte man benötigt, oder man definiert die Hausnummern und das Schema. Das in Deutschland verbreitete System mit nachgestellten Buchstaben (14, 14a, 14b, …) unterstützt Terracer allerdings nicht, es können nur ganze Zahlen verwendet werden.

Die Aufteilung der Häuser erfolgt immer symmetrisch. Auf dem Beispielbild gibt es einmal kreisförmig fortlaufend nummerierte Gebäude (erstellt mittels zwei Kreisbögen durch UtilsPlugin2), und einmal zwei wechselseitig nummerierte Häuserzeilen.

Verwendung

Da eine Einführung in die OSM-Datenverwaltung und die JOSM-Bedienung den Rahmen dieses Artikels sprengen würden, sei für eine tiefer gehende Einführung auf die Weblinks und die selbständige Webrecherche verwiesen. OSM hat eine sehr starke deutsche Community, so dass alle relevanten Dinge zu OSM und auch zu JOSM im Regelfall auch auf Deutsch verfügbar sind.

Der generelle Arbeitsablauf ist derart, dass man sich eine Karte in den Hintergrund legt, oder bestehende Luftbilder verwendet, und anhand dieser durch Flächen, Linien und Punkte die Karte erstellt. Dabei sind die Lizenzbedingungen zu beachten (vgl. hierzu die FAQ zu Quelldaten Sprache de.png). Alternativ kann man auch selbst aufgezeichnete GPS-Tracks laden, und diese als Mapping-Grundlage benutzen.

Nachdem man die Kartenelemente erstellt oder angepasst hat, lädt man das Ergebnis über „Hochladen“ in die OSM-Datenbank, man kann die Daten auch lokal speichern, und später daran weiterarbeiten. Nach dem Hochladen dauert es einige Minuten, bis Mapnik (der OSM-Standard-Renderer) aus den neuen Daten die entsprechenden Kartenkacheln generiert hat.

Siehe auch

  • Merkaartor – ein anderer, etwas einfacherer, OSM-Editor

Weblinks