GIMP

Aus wiki.archlinux.de
Version vom 22. Februar 2014, 16:10 Uhr von Dirk (Diskussion | Beiträge) (Verwendung: Anpassung wg. Erwähnung des Startens im Installationsabschnitt)

(Unterschied) ← Nächstältere Version | Aktuelle Version (Unterschied) | Nächstjüngere Version → (Unterschied)
Wechseln zu: Navigation, Suche
Der Startbildschirm von GIMP 2.8.x

GIMP ist ein mächtiges, plugin- und scriptbasiert erweiterbares, GTK-basierendes Bildbearbeitungsprogramm (tatsächlich ist es so, dass GTK aus GIMP hervorging). Schwerpunkt ist die Bearbeitung von Bitmap-Einzelbildern. GIMP unterstützt aber auch eingeschränkt Animationen und Vektorgrafiken.

Installation

GIMP ist als gimp in extra verfügbar, und kann von dort mittels Pacman installiert werden.

# GIMP an sich
pacman -S gimp

# Für den integrierten Hilfebrowser
pacman -S gimp-help-de webkitgtk2

GIMP ist mittels gimp startbar, der Hilfebrowser ist über alle Bildfenster in „Hilfe → Hilfe“ aufrufbar. Wenn die Zusatzpakete für den Hilfebrowser nicht installiert wurden, bietet der Dialog die Möglichkeit, die Onlinehilfe aufzurufen.

Verwendung

Der Mehrfenstermodus mit zwei geöffneten Bildern
Zwei geöffnete Bilder im Einzelfenstermodus
Bildexport nach PNG

Standardmäßig präsentiert GIMP sich im Mehrfenstermodus. Über „Fenster → Einzelfenstermodus“ kann seit GIMP 2.8 in einen Einzelfenstermodus geschaltet werden, in dem der Werkzeugkasten und weitere Docks sowie alle Bildfenster als Tabs in einem Fenster angezeigt werden.

Das Hauptmenü befindet sich in jedem Bildfenster. Über „Bearbeiten → Einstellungen“ kann man sich das Programm auf die individuellen Bedürfnisse zuschneiden. Im „Bearbeiten“-Menü befinden sich zudem noch vier weitere generelle Optionen (inklusive „Einstellungen“, die letzten fünf Optionen im Menü). Alle anderen Menüeinträge beziehen sich jeweils auf das jeweilige Bild.

Wichtig ist: „Datei → Beenden“ beendet GIMP, nicht die Bearbeitung des jeweiligen Bildes. Dies kann man unter „Datei → Schließen“ bewerkstelligen.

Will man ein Bild speichern bieten sich mehrere Möglichkeiten: „Speichern/Speichern unter“ speichert das Bild ausschließlich in einem der von GIMP benutzten Formate (standardmäßig Wikipedia.png XCF) ab. Will man ein Bild veröffentlichen oder in anderen Programmen weiterverarbeiten, so muss man es über „Exportieren/Exportieren nach“ in ein anderes Format als XCF exportieren. Alternativ kann man über „Vorlage erstellen“ eine Bildvorlage erstellen, die man bei Erstellung eines neuen Bildes auswählen kann.

Die Bearbeitung selbst gestaltet sich derart, dass man mehrere Bildebenen hat, auf denen man unabhängig voneinander Bildinhalte erstellen und ändern kann. Effekte und Filter beeinflussen im Normalfall immer die aktuelle Auswahl oder Ebene. In den Weblinks finden sich einige Seiten mit Tutorials.

Scripte und Plugins

Der Skript-Fu-Browser mit der Suche nach layer
Die Skript-Fu-Konsole mit einigen einfachen Beispielen

Scripte und Plugins für GIMP können entweder zum Beispiel in der GIMP Plugin Registry (siehe Weblinks) heruntergeladen, oder mittels Scheme oder Python selbst erstellt werden. Scheme ist eine sehr alte, aber sehr zuverlässige, und schnelle Sprache.

Mit Skript-Fu (egal, ob mit Scheme oder Python) kann man alles bewerkstelligen, was auch manuell mit GIMP möglich ist. Hierzu bietet GIMP über den Skript-Fu-Browser („Hilfe → Prozedurenbrowser“) Zugriff auf alle GIMP-Funktionen zur Bearbeitung von Bildern. Zusätzlich findet man über „Hilfe → Plugin-Browser“ alle von GIMP geladenen Plugins.

Beide Browser zeigen für alle Prozeduren und Plugins auch deren Effekt, Verwendung, und Parameter an. Über „Filter → Skript-Fu → Konsole“ erreicht man eine interaktive Konsole, in der man Scheme-Einzeiler eingeben und deren Ausgabe prüfen kann.

Es empfiehlt sich, zumindest für die Entwicklungszeit die Tastenkombination zum Neuladen der Scripte auf zum Beispiel F5 zu legen, und den Einbindungspfad (siehe Skript-Fu-Dokumentationen bei den Weblinks) einfach auf <image>/Scriptname zu setzen, um das Script schnell neu zu laden und aufrufen zu können.

Weblinks

Aufgrund des Umfangs der einzelnen Teilbereiche von GIMP sind die Weblinks in drei Abschnitte unterteilt. Zum Einen gibt es generelle Links, zum Anderen sind auch einige Tutorial-Links sowie links zu Plugins und Scripts. Dann gibt es auch noch einen Bereich, der Links zu weiterführenden Tutorials und Informationen über Skript-Fu beinhaltet.

Generell

Lernen und erweitern

Scripting